skip to Main Content
+30-6944453971 info [a] selidamou.gr

Qtranslate and php 7.1 error

Το Qtranslate είναι ένα project που δεν ανανεώνεται πλέον από τους δημιουργούς του. Με την php 7.1 ενεργή εμφανίζεται το παρακάτω error.

Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /var/www/DOMAIN/htdocs/wordpress/wp-includes/class-wp-hook.php on line 298

 

Τι γίνεται όμως με τις σελίδες που ήδη χρησιμοποιείται και δεν χρειάζεται να γίνει κάποια αλλαγή. Πρέπει να αλλάξετε χειροκίνητα τα παρακάτω αρχεία.

 

Στο αρχείο qtranslate-x/qtranslate_frontend.php

Σειρά 523 από

function qtranxf_postsFilter($posts,&$query) {//WP_Query

σε

function qtranxf_postsFilter($posts,$query) {//WP_Query

και στη σειρά 597 από

function qtranxf_excludeUntranslatedPosts($where,&$query) {//WP_Query

σε

function qtranxf_excludeUntranslatedPosts($where,$query) {//WP_Query

 

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *

Back To Top
×Close search
Search